Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 06, 2025 - 04:00 UTC
Scheduled
Dear Valued Customers,
We would like to inform you of an upcoming Planned maintenance activity that will be performed on the following F5 service: - F5 Distributed CDN Cloud Global Controller
Maintenance Window: Start Time: 06 Dec 2025 04:00 UTC End Time: 06 Dec 2025 08:00 UTC
Reference: SDCCAB-2446
Projected Impact: During this maintenance window, customers will be unable to configure or modify CDN distributions, and the purge functionality will also be unavailable.
Reason for Maintenance: We will be upgrading the F5 Distributed Cloud CDN Controller to the latest software version to enhance performance, stability, and overall service reliability.
Our Commitment: We will provide timely updates should there be any changes to the schedule or if unexpected issues arise.
Contact Information: If you have any questions or need further assistance, please contact our support team at support@cloud.f5.com or call us at 1-888-882-7535.
We appreciate your cooperation and understanding as we work to improve our services.
Sincerely, F5 Distributed Cloud
Posted Nov 21, 2025 - 23:18 UTC
This scheduled maintenance affected: Services (CDN Control Plane).