We would like to inform you that the ongoing maintenance for F5 Distributed Cloud Global Controller has been extended by an additional 2 hours. The new expected completion time is August 13th at 10:00 AM UTC.
We sincerely appreciate your patience and understanding as we carry out this critical maintenance to further enhance the quality and reliability of our services.
Sincerely, F5 Distributed Cloud Team
Posted Aug 13, 2026 - 07:34 UTC
Update
Dear Valued Customer,
We would like to inform you that the ongoing maintenance for F5 Distributed Cloud Global Controller has been extended by an additional 1 hour. The new expected completion time is August 13th at 08:00 AM UTC.
We sincerely appreciate your patience and understanding as we carry out this critical maintenance to further enhance the quality and reliability of our services.
Sincerely, F5 Distributed Cloud Team
Posted Aug 13, 2026 - 06:45 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 13, 2026 - 04:00 UTC
Scheduled
Dear Valued Customers,
We would like to inform you of an upcoming Urgent Scheduled maintenance activity that will be performed on the following F5 service: - F5 Distributed Cloud Global Controller
Maintenance Window: Start Time: 13 Aug 2026 04:00 UTC End Time: 13 Aug 2026 07:00 UTC
Reference: SDCCAB-4920
Projected Impact: During this maintenance window, configuration changes will continue to be processed for most of the upgrade. Sign-in services for the Distributed Cloud Console may experience brief, intermittent accessibility while upgrades are being performed. Access will be restored automatically shortly after each upgrade step is completed.
Reason for Maintenance: As part of our ongoing commitment to providing a reliable experience, this update includes important enhancements and improvements to platform stability, performance, and reliability.
Our Commitment: We will provide timely updates should there be any changes to the schedule or if unexpected issues arise.