F5 Distributed Cloud - Service Interruption - XC Console is Down

Incident Report for F5

Resolved

The F5 Distributed Cloud team has validated and confirmed that the issue with the XC Console has been resolved. All other services remain fully operational.
Posted Apr 28, 2025 - 10:00 UTC

Monitoring

The F5 Distributed Cloud team has mitigated the access issue. Users can now connect to the XC Console and it is operating normally. We will continue to proactively monitor the situation to ensure the stability of our services.
Posted Apr 28, 2025 - 07:12 UTC

Investigating

F5 Distributed Cloud support team detected an issue with XC Console that might interrupt our services to you and we are currently working to restore the service as quickly as possible. We will provide further updates as they become available.
Posted Apr 28, 2025 - 06:46 UTC
This incident affected: Services (Portal & Customer Login, Customer Dashboard).