We would like to inform you that the ongoing maintenance for Global Controller has been extended by 4 hours and is expected to be completed by Sep 20th 12:00PM UTC.
We appreciate your cooperation and understanding as we carry out this important maintenance to enhance our services.
Sincerely, F5 Distributed Cloud Team
Posted Sep 20, 2025 - 05:52 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 20, 2025 - 04:00 UTC
Update
Dear Valued Customers,
We would like to inform you that the previously scheduled maintenance for Distributed Cloud Global Controller has been rescheduled.
Updated Maintenance schedule in UTC time: - Time: Sep 20th 04:00AM UTC to Sep 20th 08:00AM UTC
Reason for Reschedule: Rescheduled to prioritize more urgent operational activities.
We apologize for any inconvenience caused and appreciate your cooperation and understanding as we work to improve our services.
If you have any questions or concerns, please do not hesitate to contact us at support@cloud.f5.com.
Sincerely, F5 Distributed Cloud
Posted Sep 10, 2025 - 00:53 UTC
Scheduled
Dear Valued Customers,
We would like to inform you in advance of an upcoming planned maintenance window for the following F5 services:
- F5 Distributed Cloud Global Controller
Maintenance activities will include: 1. Upgrade F5 Distributed Cloud Global Controller to the latest software version i.e. 6.1. 2. Improved synchronization and alignment of data between global controllers and regional edges.
Maintenance schedule in UTC time: - Time: Sep 14th 04:00AM UTC to Sep 14th 08:00AM UTC
Projected Impact: Management plane configuration changes will persist and actively propagate throughout the majority of upgrade process. However, there will be a temporary pause in config propagation during the upgrade of the config audit service
If you have any questions or concerns, please do not hesitate to contact us at support@cloud.f5.com.
Thank you for your understanding and cooperation
Posted Sep 03, 2025 - 05:51 UTC
This scheduled maintenance affected: Services (Portal & Customer Login).