The F5 CDN issue for existing and newly created CDN distributions has been restored, and the CDN Services are now operating normally. Our engineering teams have completed recovery activities and are actively monitoring the environment to ensure continued stability. Existing CDN services and traffic processing remain fully operational. We will continue to monitor the situation closely and provide further updates as necessary.
Posted Jun 16, 2026 - 18:22 UTC
Identified
The F5 CDN Dashboard and Purge services have been successfully restored and are functioning normally. Restoration activities for CDN distribution provisioning remain in progress, and our engineering teams continue to actively monitor the environment to ensure service stability. Existing CDN services remain operational, and traffic processing continues to be unaffected. We will provide further updates as restoration efforts continue.
Posted Jun 16, 2026 - 16:18 UTC
Update
As part of our ongoing efforts to resolve the issue affecting CDN distributions that are becoming stuck in a pending state, our engineering teams will be performing a restart of the CDN service, existing and newly created CDN distributions to become stuck in a pending state during this period and expected failures of Dashboard population and Purge config operation services. Traffic processing is not expected to be impacted. We are closely monitoring the environment throughout the maintenance and will provide further updates on the outcome of these actions. Thank you for your continued patience and understanding.
Posted Jun 16, 2026 - 13:59 UTC
Update
Our engineering teams remain actively engaged in investigating the issue affecting CDN distributions that are becoming stuck in a pending state. At this time, there are no changes to the scope or impact of the issue. Existing CDN services continue to operate normally, and traffic processing remains unaffected. The team is continuing its analysis and working toward identifying the cause and implementing a resolution. We appreciate your continued patience and will provide further updates as additional information becomes available.
Posted Jun 16, 2026 - 13:40 UTC
Update
Our engineering teams are actively engaged and continue to work toward identifying the potential cause and implementing a resolution. Existing CDN services remain operational, and traffic processing is not impacted. We will continue to provide regular updates as our investigation progresses.
Posted Jun 16, 2026 - 11:47 UTC
Update
F5 Distributed Cloud team is aware of an issue causing both existing and newly created CDN distributions to become stuck in a pending state. Existing CDN services remain operational, and traffic processing is not impacted. Our engineering teams are actively investigating the issue and working to restore normal functionality as quickly as possible. We will provide further updates as additional information becomes available. Thank you for your patience and understanding.
Posted Jun 16, 2026 - 10:06 UTC
Investigating
This advisory is to inform you that we are currently investigating reports of service degradation affecting F5 CDN distribution.
We understand this may be affecting your operations and we are committed to providing transparent and timely updates as more information becomes available. While we gather more information, we recommend monitoring the progress on this site (https://www.f5cloudstatus.com/) for the latest update.
Investigation Status: • We have identified potential service impact at 09:35 AM UTC; • Our incident response team has been fully mobilized; • Initial investigation and impact assessment efforts are underway. Next Steps: • A detailed incident notification will be provided within 30 minutes; • Our teams are working to determine the root cause of the incident; • We will share mitigation steps as soon as they become available.
We appreciate your patience as we work to resolve this situation. If you are experiencing a critical business impact, please contact our support team through your established channels.
Thank you for your continued support and trust in F5.
Posted Jun 16, 2026 - 09:36 UTC
This incident affects: Services (CDN Control Plane).