We've updated our notification for F5 Distributed Cloud Atlanta Regional Edge PoP commissioning. The commissioning and integration is scheduled for April 16, 2026 at 4:00 am UTC and not April 15, 2025 as previously communicated. We apologize for any confusion this may have caused.
Questions? Our team is here to help. Reach out to us at support@cloud.f5.com. — The F5 Distributed Cloud Team
Posted Apr 14, 2026 - 16:59 UTC
Monitoring
Dear Valued Customers,
We are pleased to announce the launch of a new Regional Edge cluster Atlanta (At1-atl), which marks a significant step in enhancing the resilience and reliability of our North America Regional Edge infrastructure.
The addition of the At1-atl Regional Edge cluster brings substantial improvements to our operational capabilities by:
Enhancing Redundancy: By distributing workloads across this new cluster, we ensure better failover capabilities, minimizing service disruptions during potential outages.
Reinforcing Fault Tolerance: The At1-atl cluster strengthens our overall infrastructure by efficiently managing traffic spikes and better balancing regional workloads, ultimately offering a more robust and reliable experience for our users.
This development underscores our commitment to delivering greater availability, stability, and service quality across the North America Regional Edge network.
Time: At1-atl will go live on April 16 2026 at 4:00 am UTC
If you have any questions or concerns, please do not hesitate to contact us at support@cloud.f5.com.
Posted Apr 08, 2026 - 03:21 UTC
This incident affected: North America PoPs (Atlanta, GA, United States (Network)).