Service Provider Incident Notification for F5 Distributed Cloud Services in Dubai and Tel Aviv Region [INC- 20250531-316]

Incident Report for F5

Resolved

This incident has been successfully resolved by our service provider. The F5 Distributed Cloud team has verified that all services are stable and functioning as expected. If you experience any issues or notice unusual behaviour, please don't hesitate to reach out to our Support team for prompt assistance.
Posted Jun 01, 2025 - 11:06 UTC

Monitoring

The F5 Distributed Cloud team would like to inform you that connectivity has been restored at both Dubai (DX1) and Tel Aviv (SDS3) Regional Edges. We will continue to monitor the same to ensure our services remain stable and operational. If you're experiencing any service degradation, please contact our support team to follow up accordingly.
Posted May 31, 2025 - 18:46 UTC

Identified

Our provider has identified a double fiber cut in their network. At this time, there is no estimated time to repair. Services remain operational, though they may be at risk due to a temporary loss of redundancy.
We are closely monitoring the situation and will continue to keep you informed as soon as we receive further updates.

Thank you for your patience and understanding.
Posted May 31, 2025 - 15:05 UTC

Investigating

Dear Valued Customer,

We want to inform you about an ongoing service provider incident. We are actively coordinating with our partner and will share updates as soon as more information becomes available.

Incident Details:
Start Time: 31/05/25 13:15 UTC
Estimated Date of Restoration: NA
Reference ID: #316

Impact:
None expected. Services will remain operational, though they may be at risk due to a temporary loss of redundancy.

Contact Information:
If you have any questions or need further assistance, please contact our support team at support@cloud.f5.com.

We appreciate your cooperation and understanding as we work to improve our services.

Sincerely,
F5 Distributed Cloud
Posted May 31, 2025 - 13:27 UTC
This incident affected: Middle East PoPs (Dubai, United Arab Emirates, Tel Aviv, Israel) and Services (Routed Originated Services).