We would like to inform you that the ongoing maintenance for F5 Distributed Cloud Regional Edge Sites in Sydney has been extended by an additional hour. The new expected completion time is 18 May 2026 21:00 UTC.
We sincerely appreciate your patience and understanding as we carry out this critical maintenance to further enhance the quality and reliability of our services.Sincerely, F5 Distributed Cloud Team
Posted May 18, 2026 - 19:50 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 18, 2026 - 17:25 UTC
Scheduled
Dear Valued Customers,
We would like to inform you that the Engineering team is still working on the Sydney Regional Edge issue. An additional 4 hours will be needed to complete the activity. This serves as an update to the previous notification.
As part of our ongoing commitment to security, reliability, and performance, we will be conducting a urgent maintenance activity that will be performed on the following F5 service: - F5 Distributed Cloud Regional Edge Sites in Sydney
Maintenance Window: Start Time: 18 May 2026 11:00 UTC End Time: 18 May 2026 20:00 UTC
Projected Impact: 1. Customers who have created hard-coded dependencies for Regional Edge site may encounter a service interruption during this window. 2. Services and applications should remain unaffected and will continue to be served from other Regional Edges within the same region.
Rest assured, Customer Edge (CE) services and applications will not experience any downtime during this maintenance window.
Reason for Maintenance: This maintenance activity involves improvements to security, reliability, and performance.
Our Commitment: We will provide timely updates should there be any changes to the schedule or if unexpected issues arise.