Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 14, 2025 - 05:00 UTC
Scheduled
Dear Valued Customers,
We would like to inform you of an upcoming Urgent Scheduled maintenance activity that will be performed on the following F5 service: - F5 Distributed Cloud Global Controller
Maintenance Window: Start Time: 14 Nov 2025 05:00 UTC End Time: 14 Nov 2025 08:00 UTC Reference: SDCCAB-2191
Projected Impact: No performance or service impact is expected.
Reason for Maintenance: We are planning to upgrade select Kubernetes components in preparation for the scheduled software release upgrade on November 15th.
Our Commitment: We will provide timely updates should there be any changes to the schedule or if unexpected issues arise.
Contact Information: If you have any questions or need further assistance, please contact our support team at support@cloud.f5.com.
We appreciate your cooperation and understanding as we work to improve our services.
Sincerely, F5 Distributed Cloud
Posted Nov 13, 2025 - 20:21 UTC
This scheduled maintenance affected: Services (Portal & Customer Login).